aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2019-10-09 11:12:55 -0400
committerCarl Dong <contact@carldong.me>2019-10-09 11:12:55 -0400
commit181989f6c9427fc266dbdcc84cb60ac03e67cdb2 (patch)
tree656850d3abbd244f2ccc94583188b7e85555d514 /Makefile.am
parent1c11e53bb604835afd838f4520d3fdba25521c5b (diff)
downloadbitcoin-181989f6c9427fc266dbdcc84cb60ac03e67cdb2.tar.xz
build: Add variable printing target to Makefiles
I kept finding myself needing these to debug our build system, since they are innocuous and are very helpful they probably belong in the codebase. Source: John Graham-Cumming https://www.cmcrossroads.com/article/printing-value-makefile-variable
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b1e2a6b5b..49a20b7614 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,10 @@
# Distributed under the MIT software license, see the accompanying
# file COPYING or http://www.opensource.org/licenses/mit-license.php.
+# Pattern rule to print variables, e.g. make print-top_srcdir
+print-%:
+ @echo $* = $($*)
+
ACLOCAL_AMFLAGS = -I build-aux/m4
SUBDIRS = src
if ENABLE_MAN