aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authoreugene <elzeigel@gmail.com>2020-09-08 02:45:42 -0400
committereugene <elzeigel@gmail.com>2020-09-08 02:45:42 -0400
commita9f201439a84096a209bebc11705656b08d1b488 (patch)
treeb5e8a90ef3b100320bd7a86863c9591b9a6e4edf /Makefile.am
parent147d50d63e07f600b414273a9f6b84f9f4ad9696 (diff)
downloadbitcoin-a9f201439a84096a209bebc11705656b08d1b488.tar.xz
build: use DIR_FUZZ_SEED_CORPUS if specified for cov_fuzz target
This commit allows the user to specify the location of the fuzz_seed_corpus directory on their machine when running the cov_fuzz target. If DIR_FUZZ_SEED_CORPUS is specified, then this will be used. Otherwise, qa-assets/fuzz_seed_corpus is assumed to be in the bitcoin directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8cdd3ff647..c8af4228f3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -193,6 +193,8 @@ LCOV_FILTER_PATTERN = \
-p "src/secp256k1" \
-p "depends"
+DIR_FUZZ_SEED_CORPUS ?= qa-assets/fuzz_seed_corpus
+
$(COV_TOOL_WRAPPER):
@echo 'exec $(COV_TOOL) "$$@"' > $(COV_TOOL_WRAPPER)
@chmod +x $(COV_TOOL_WRAPPER)
@@ -205,7 +207,7 @@ baseline_filtered.info: baseline.info
$(LCOV) -a $@ $(LCOV_OPTS) -o $@
fuzz.info: baseline_filtered.info
- @TIMEOUT=15 test/fuzz/test_runner.py qa-assets/fuzz_seed_corpus -l DEBUG
+ @TIMEOUT=15 test/fuzz/test_runner.py $(DIR_FUZZ_SEED_CORPUS) -l DEBUG
$(LCOV) -c $(LCOV_OPTS) -d $(abs_builddir)/src --t fuzz-tests -o $@
$(LCOV) -z $(LCOV_OPTS) -d $(abs_builddir)/src