aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2018-09-20 14:03:00 -0400
committerMarcoFalke <falke.marco@gmail.com>2018-09-20 14:01:53 -0400
commitfa6b30c40b84b58f9c5327481a91292e23ed3a7c (patch)
tree33f132c5365f851815c6993b4f0b36b7b329bdff /Makefile.am
parentd26278988fbfc71dc558f7b2c60a184e8091450b (diff)
downloadbitcoin-fa6b30c40b84b58f9c5327481a91292e23ed3a7c.tar.xz
lcov: filter /usr/lib/ from coverage reports
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 10dda65b21..eec9f72215 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -168,7 +168,7 @@ $(BITCOIN_CLI_BIN): FORCE
$(MAKE) -C src $(@F)
if USE_LCOV
-LCOV_FILTER_PATTERN=-p "/usr/include/" -p "src/leveldb/" -p "src/bench/" -p "src/univalue" -p "src/crypto/ctaes" -p "src/secp256k1"
+LCOV_FILTER_PATTERN=-p "/usr/include/" -p "/usr/lib/" -p "src/leveldb/" -p "src/bench/" -p "src/univalue" -p "src/crypto/ctaes" -p "src/secp256k1"
baseline.info:
$(LCOV) -c -i -d $(abs_builddir)/src -o $@