aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2017-10-29 18:27:08 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2017-10-29 18:28:21 +0100
commitbb9ab0fccfbadd5c032a2cd0bb3135049cffa42b (patch)
tree6e37500eb35dbe63b1a64066380bd3cb4effb98b /Makefile.am
parentba216b5fa63e7e6cae847d1e3621f5c54840f898 (diff)
parentcc5c39ddca4cf5e01c45fdf69462f50ac984e264 (diff)
downloadbitcoin-bb9ab0fccfbadd5c032a2cd0bb3135049cffa42b.tar.xz
Merge #11541: Build: Fix Automake warnings when running autogen.sh
cc5c39d [Build] Add AM_OBJCXXFLAGS and QT_PIE_FLAGS to OBJCXXFLAGS to future-proof darwin targets (fanquake) f8c6697 Fix automake warnings when running autogen.sh (Evan Klitzke) Pull request description: Adjusted @eklitzke's commit to completely remove GZIP_ENV. Added a commit to address OBJCXXFLAGS. Rebased on master. Relevant info from @theuni & #11013 below. -------- GZIP_ENV was indeed added for determinism, but gitian exports this as needed, so it's not really necessary. I'd rather just remove it. The mm.o rule was added to support XCode 4.2's ancient version of automake. That's irrelevant now, so it makes sense to remove that too. All darwin targets are PIE by default, so we don't technically need the flags, but I'd be more comfortable if we hooked up the OBJCXXFLAGS in case future ones are added. -------- The second commit addresses the last point, but could probably use a better commit message. These warnings are removed from autogen output: ``` Makefile.am:12: warning: user variable 'GZIP_ENV' defined here ... /usr/local/Cellar/automake/1.15.1/share/automake-1.15/am/distdir.am: ... overrides Automake variable 'GZIP_ENV' defined here src/Makefile.am: installing 'build-aux/depcomp' src/Makefile.am:503: warning: user target '.mm.o' defined here ... /usr/local/Cellar/automake/1.15.1/share/automake-1.15/am/depend2.am: ... overrides Automake target '.mm.o' defined here ``` Tree-SHA512: bd59df5f6d3aafe35d5e36925bfe61cc71e774583a0438d7dd946c9e7ecf6e59d42f90a58b8cfef0faa404c81050338ad4cefe721b4a949af881e73b6ab254d4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ad522f5a56..a7092bb334 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,6 @@ SUBDIRS += doc/man
endif
.PHONY: deploy FORCE
-GZIP_ENV="-9n"
export PYTHONPATH
if BUILD_BITCOIN_LIBS