aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2016-06-01 18:47:21 -0400
committerCory Fields <cory-nospam-@coryfields.com>2016-06-01 20:31:55 -0400
commitab95d5df3dc492c6355c78686c559527622fe033 (patch)
tree4c7e64d92d4081125852edaa75cf779408bf6c98 /Makefile.am
parentfc4ad0c7fcf2e5841756c9d1003f95c879ee5cd2 (diff)
downloadbitcoin-ab95d5df3dc492c6355c78686c559527622fe033.tar.xz
build: a few ugly hacks to get the rpc tests working out-of-tree
- Link pull-tester/rpc-tests.py to the build dir - Add the build-dir's config to the python path so that tests can find it - The tests themselves are in srcdir - Clean up __pycache__ in 'make clean'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bfdf76568a..9957968f81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -228,3 +228,4 @@ CLEANFILES = $(OSX_DMG) $(BITCOIN_WIN_INSTALLER)
clean-local:
rm -rf coverage_percent.txt test_bitcoin.coverage/ total.coverage/ qa/tmp/ cache/ $(OSX_APP)
+ rm -rf qa/pull-tester/__pycache__