aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2019-02-14 16:32:16 -0500
committerMarcoFalke <falke.marco@gmail.com>2019-02-14 16:32:26 -0500
commit31f7c6dd21528f793ce61912d30c2a85079e1d7a (patch)
tree82f7629ee4e17ba3a29128ec2039bf7cb62a97b4 /Makefile.am
parent642bd7bbe747399d9e08a9b76a4a97f0e875c487 (diff)
parentfa535af92c179b0ffb9280e0b2dc5acfeb80964a (diff)
downloadbitcoin-31f7c6dd21528f793ce61912d30c2a85079e1d7a.tar.xz
Merge #15295: fuzz: Add test/fuzz/test_runner.py and run it in travis
fa535af92c fuzz: test_runner: Better error message when built with afl (MarcoFalke) fa7ca8ef58 qa: Add test/fuzz/test_runner.py (MarcoFalke) Pull request description: Can be run with `./test/fuzz/test_runner.py` after building as described in `doc/fuzzing.md` Tree-SHA512: f6a3cd8165ec2de4b363be4fd0a936b4a60829cce923f93fe5d6a046b1bbd64c959cdf790440bf70c0e13b0bb1b956a746a24c6fd92bddeab15b837ed50ffad2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 287ba3ab3a..85674f819a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -225,7 +225,11 @@ endif
dist_noinst_SCRIPTS = autogen.sh
-EXTRA_DIST = $(DIST_SHARE) test/functional/test_runner.py test/functional $(DIST_CONTRIB) $(DIST_DOCS) $(WINDOWS_PACKAGING) $(OSX_PACKAGING) $(BIN_CHECKS)
+EXTRA_DIST = $(DIST_SHARE) $(DIST_CONTRIB) $(DIST_DOCS) $(WINDOWS_PACKAGING) $(OSX_PACKAGING) $(BIN_CHECKS)
+
+EXTRA_DIST += \
+ test/functional \
+ test/fuzz
EXTRA_DIST += \
test/util/bitcoin-util-test.py \