aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordexX7 <dexx@bitwatch.co>2015-10-12 14:29:44 +0200
committerdexX7 <dexx@bitwatch.co>2015-10-23 22:09:20 +0200
commite3b5e6c39c5a6e56bdc21d307ac5cb6c80b737dd (patch)
tree5b7526c264da7733d7e178d36316bfae0aa66cf1 /Makefile.am
parent45d4ff0c2094813e8a1c5446e728449157a289b8 (diff)
downloadbitcoin-e3b5e6c39c5a6e56bdc21d307ac5cb6c80b737dd.tar.xz
Run extended BitcoinJ tests for coverage based on config
The configuration option `--enable-comparison-tool-reorg-tests` may be used to enable extended tests via BitcoinJ also for coverage testing.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 93a768b1c1..8b298619f7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -170,7 +170,7 @@ test_bitcoin_filtered.info: test_bitcoin.info
block_test.info: test_bitcoin_filtered.info
$(MKDIR_P) qa/tmp
- -@TIMEOUT=15 qa/pull-tester/run-bitcoind-for-test.sh $(JAVA) -jar $(JAVA_COMPARISON_TOOL) qa/tmp/compTool 0
+ -@TIMEOUT=15 qa/pull-tester/run-bitcoind-for-test.sh $(JAVA) -jar $(JAVA_COMPARISON_TOOL) qa/tmp/compTool $(COMPARISON_TOOL_REORG_TESTS)
$(LCOV) -c -d $(abs_builddir)/src --t BitcoinJBlockTest -o $@
$(LCOV) -z -d $(abs_builddir)/src
$(LCOV) -z -d $(abs_builddir)/src/leveldb