aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authornomnombtc <mastergizmo@arcor.de>2016-08-27 01:09:22 +0200
committernomnombtc <mastergizmo@arcor.de>2016-08-27 01:09:22 +0200
commitdc84b6f4192828abd1c0c7a0960445870346c5c7 (patch)
treecde3224526231d69c883dc57bc2244c1d16b8efb /Makefile.am
parent00dba72cc3674f3cf60ac42c78d5792264c78e94 (diff)
downloadbitcoin-dc84b6f4192828abd1c0c7a0960445870346c5c7.tar.xz
add doc/man to subdir if configure flag --enable-man is set
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 37c1e98eca..2e061c3773 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,8 @@
ACLOCAL_AMFLAGS = -I build-aux/m4
SUBDIRS = src
+if ENABLE_MAN
+SUBDIRS += doc/man
+endif
.PHONY: deploy FORCE
GZIP_ENV="-9n"
@@ -213,6 +216,8 @@ DISTCLEANFILES = qa/pull-tester/tests_config.pyc
.INTERMEDIATE: $(COVERAGE_INFO)
+DISTCHECK_CONFIGURE_FLAGS = --enable-man
+
clean-local:
rm -rf coverage_percent.txt test_bitcoin.coverage/ total.coverage/ qa/tmp/ cache/ $(OSX_APP)
rm -rf qa/pull-tester/__pycache__