aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Newbery <john@johnnewbery.com>2017-03-09 09:53:26 -0500
committerJohn Newbery <john@johnnewbery.com>2017-03-20 10:40:31 -0400
commita9bd622a658b41b219912288e643f5e2c1b145b4 (patch)
tree89f707400730826e3514e9d62eb4ac48c003cb2f /Makefile.am
parentc28ee91db07ce82e134d500ddeb5600363c98048 (diff)
downloadbitcoin-a9bd622a658b41b219912288e643f5e2c1b145b4.tar.xz
Rename test/pull-tester/rpc-tests.py to test/functional/test_runner.py
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0316d9254f..236d413b35 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -195,7 +195,7 @@ test_bitcoin_filtered.info: test_bitcoin.info
$(LCOV) -r $< "/usr/include/*" -o $@
functional_test.info: test_bitcoin_filtered.info
- -@TIMEOUT=15 python test/pull-tester/rpc-tests.py $(EXTENDED_RPC_TESTS)
+ -@TIMEOUT=15 python test/functional/test_runner.py $(EXTENDED_RPC_TESTS)
$(LCOV) -c -d $(abs_builddir)/src --t functional-tests -o $@
$(LCOV) -z -d $(abs_builddir)/src
$(LCOV) -z -d $(abs_builddir)/src/leveldb
@@ -223,7 +223,7 @@ endif
dist_noinst_SCRIPTS = autogen.sh
-EXTRA_DIST = $(top_srcdir)/share/genbuild.sh test/pull-tester/rpc-tests.py test/functional $(DIST_CONTRIB) $(DIST_DOCS) $(WINDOWS_PACKAGING) $(OSX_PACKAGING) $(BIN_CHECKS)
+EXTRA_DIST = $(top_srcdir)/share/genbuild.sh test/functional/test_runner.py test/functional $(DIST_CONTRIB) $(DIST_DOCS) $(WINDOWS_PACKAGING) $(OSX_PACKAGING) $(BIN_CHECKS)
CLEANFILES = $(OSX_DMG) $(BITCOIN_WIN_INSTALLER)
@@ -233,4 +233,4 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-man
clean-local:
rm -rf coverage_percent.txt test_bitcoin.coverage/ total.coverage/ test/tmp/ cache/ $(OSX_APP)
- rm -rf test/pull-tester/__pycache__
+ rm -rf test/functional/__pycache__