aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Newbery <john@johnnewbery.com>2017-03-21 15:01:48 -0400
committerJohn Newbery <john@johnnewbery.com>2017-06-06 16:42:38 -0400
commit8ad5bdef781d9b3009030287e5c99341e6933007 (patch)
tree34ccda80c4a98576e8b07dcf3606030de8a4ec11 /Makefile.am
parent95836c5eba4a6cdc835e72189e4b0fe3e9458c5a (diff)
downloadbitcoin-8ad5bdef781d9b3009030287e5c99341e6933007.tar.xz
Merge bctest.py into bitcoin-util-test.py
bctest.py is only used as an import by bitcoin-util-test.py. There's no value in keeping it as a separate module, so let's merge them into a single module to keep building and packaging simpler. bitcoin-test-util is importable as a module, so if any future modules really want to import the code from bctest.py, they can import bitcoin-test-util and call the bctest functions by name.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b0ba0c8504..40114a551f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -223,7 +223,6 @@ dist_noinst_SCRIPTS = autogen.sh
EXTRA_DIST = $(top_srcdir)/share/genbuild.sh test/functional/test_runner.py test/functional $(DIST_CONTRIB) $(DIST_DOCS) $(WINDOWS_PACKAGING) $(OSX_PACKAGING) $(BIN_CHECKS)
EXTRA_DIST += \
- test/util/bctest.py \
test/util/bitcoin-util-test.py \
test/util/data/bitcoin-util-test.json \
test/util/data/blanktxv1.hex \