aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrea D'Amore <anddam@brapi.net>2014-03-24 17:17:29 +0100
committerAndrea D'Amore <anddam@brapi.net>2014-03-24 18:58:47 +0100
commit76cee181d3f3cf67a02b85f3af3407cbe9e10a3a (patch)
tree3bba3bdbe3457298761cb743b195f9d884f769c9 /Makefile.am
parentd3c3210fa376a9c1ce55c537a3f4439202783624 (diff)
downloadbitcoin-76cee181d3f3cf67a02b85f3af3407cbe9e10a3a.tar.xz
fix permissions in application bundle
Use INSTALL_DATA rather than INSTALL for copying non executable files in OS X application bundle. Tested by running "all appbundle" make target and trying the resulting application bundle, host system is OS X 10.9.2 .
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e26627f3e3..7a46652ec6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,11 +66,11 @@ $(OSX_APP)/Contents/Resources/empty.lproj:
$(OSX_APP)/Contents/Info.plist: $(OSX_PLIST)
$(MKDIR_P) $(@D)
- $(INSTALL) $< $@
+ $(INSTALL_DATA) $< $@
$(OSX_APP)/Contents/Resources/bitcoin.icns: $(OSX_INSTALLER_ICONS)
$(MKDIR_P) $(@D)
- $(INSTALL) $< $@
+ $(INSTALL_DATA) $< $@
$(OSX_APP)/Contents/MacOS/Bitcoin-Qt: $(BITCOIN_QT_BIN)
$(MKDIR_P) $(@D)