aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-08-04 19:11:46 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-08-06 19:29:19 -0400
commit6b271a3911b10a9d100341b8dc31ed92074a43c3 (patch)
treebcd1b5679b9e46ef36e47dc73d9b5199bbe31646 /Makefile.am
parentd3434601baa8b2b8513ae08fcac99053860165ad (diff)
downloadbitcoin-6b271a3911b10a9d100341b8dc31ed92074a43c3.tar.xz
build: fix race in 'make deploy' for windows
The binary builds can clobber eachother, so use a single subdir dependency instead.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 123a22525c..a64666a32b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,7 @@ distcheck-hook:
distcleancheck:
@:
-$(BITCOIN_WIN_INSTALLER): $(BITCOIND_BIN) $(BITCOIN_QT_BIN) $(BITCOIN_CLI_BIN)
+$(BITCOIN_WIN_INSTALLER): all-recursive
$(MKDIR_P) $(top_builddir)/release
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIND_BIN) $(top_builddir)/release
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIN_QT_BIN) $(top_builddir)/release