aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Woosley <ben.woosley@gmail.com>2018-05-16 20:07:50 -0700
committerBen Woosley <ben.woosley@gmail.com>2018-05-16 20:13:30 -0700
commit4138f42d24ae98da5816a7cce887a54c4550b6da (patch)
tree83ec474cacf794b5f43514554927b5e4723a24c8 /Makefile.am
parent4cfe17c3382ba750131cdc8703b2978132822070 (diff)
downloadbitcoin-4138f42d24ae98da5816a7cce887a54c4550b6da.tar.xz
Revert "Merge #12870: make clean removes src/qt/moc_ files"
As noted by theuni and Sjors in #12870, qt moc cleaning is handled by CLEAN_QT via QT_MOC_CPP in Makefile.qt.include. In my testing I configured, built and cleaned with qt4 and qt5 both, absent the associated wildcard, and no MOC files were left after clean. Propose we revert the change and reconsider if a specific file is identified, then add that file to QT_MOC_CPP. This reverts commit 1d540046fe47eb7b6062c55ebebd801ece96231c, reversing changes made to ad960f5771dc251c8e1198dd8a82e18df4562171.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a8debb079..0ed3dd289a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -294,5 +294,6 @@ clean-docs:
rm -rf doc/doxygen
clean-local: clean-docs
- rm -rf coverage_percent.txt test_bitcoin.coverage/ total.coverage/ test/tmp/ cache/ $(OSX_APP) src/qt/moc_*
+ rm -rf coverage_percent.txt test_bitcoin.coverage/ total.coverage/ test/tmp/ cache/ $(OSX_APP)
rm -rf test/functional/__pycache__ test/functional/test_framework/__pycache__ test/cache
+