aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2016-06-03 14:00:38 -0400
committerCory Fields <cory-nospam-@coryfields.com>2016-06-03 14:48:21 -0400
commit340012d9c978901d23ccedad5805c6630c49e756 (patch)
tree5f2441fa244470927af1b6d9d195b728ced5132d /Makefile.am
parent142ffc7e6136607b9a31709f31256f360b26588b (diff)
downloadbitcoin-340012d9c978901d23ccedad5805c6630c49e756.tar.xz
build: add temporary fix for "bad magic number" error in out-of-tree builds
This was caused by an pyc files hanging around from previous python2 invocations, when the matching .py missing from that path. This should not be a problem with python3's tagged caches.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b93748e324..b10d085066 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -224,6 +224,9 @@ EXTRA_DIST = $(top_srcdir)/share/genbuild.sh qa/pull-tester/rpc-tests.py qa/rpc-
CLEANFILES = $(OSX_DMG) $(BITCOIN_WIN_INSTALLER)
+# This file is problematic for out-of-tree builds if it exists.
+DISTCLEANFILES = qa/pull-tester/tests_config.pyc
+
.INTERMEDIATE: $(COVERAGE_INFO)
clean-local: