aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2015-05-04 12:02:24 -0400
committerCory Fields <cory-nospam-@coryfields.com>2015-05-04 12:02:24 -0400
commit00ea54642249fa537f677499b0b4e006fd277481 (patch)
tree7c839a7fe66c38ad124a02fb95918f5cb453a747 /Makefile.am
parentcc602d0f8306148ace743f4ed493ad5fe5f80958 (diff)
downloadbitcoin-00ea54642249fa537f677499b0b4e006fd277481.tar.xz
build: quiet the exe-installer output
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c59648fd02..2cb933d5bb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,8 +59,9 @@ $(BITCOIN_WIN_INSTALLER): all-recursive
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIND_BIN) $(top_builddir)/release
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIN_QT_BIN) $(top_builddir)/release
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIN_CLI_BIN) $(top_builddir)/release
- @test -f $(MAKENSIS) && $(MAKENSIS) $(top_builddir)/share/setup.nsi || \
+ @test -f $(MAKENSIS) && $(MAKENSIS) -V2 $(top_builddir)/share/setup.nsi || \
echo error: could not build $@
+ @echo built $@
$(if $(findstring src/,$(MAKECMDGOALS)),$(MAKECMDGOALS), none): FORCE
$(MAKE) -C src $(patsubst src/%,%,$@)