aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-06-10 22:26:50 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-06-10 22:29:44 -0400
commit77a055d04979dc2b3ec4064e99c69259a4216f12 (patch)
treec7010103930f03856d1da3f42968dfb4436bf917 /Makefile.am
parent3d7399cb171c2468b81a9179cb04358c56b4c7c4 (diff)
downloadbitcoin-77a055d04979dc2b3ec4064e99c69259a4216f12.tar.xz
build: Add a top-level forwarding target for src/* objects
Fixes #3955. It's hackish, but seems to always function as expected. Examples: make src/bitcoind make src/qt/bitcoin-qt make src/libbitcoin.a
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 04f8368dd7..719af42ac7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
ACLOCAL_AMFLAGS = -I src/m4
SUBDIRS = src
-.PHONY: deploy
+.PHONY: deploy FORCE
GZIP_ENV="-9n"
@@ -53,8 +53,8 @@ $(BITCOIN_WIN_INSTALLER): $(BITCOIND_BIN) $(BITCOIN_QT_BIN) $(BITCOIN_CLI_BIN)
@test -f $(MAKENSIS) && $(MAKENSIS) $(top_builddir)/share/setup.nsi || \
echo error: could not build $@
-$(BITCOIND_BIN) $(BITCOIN_QT_BIN) $(BITCOIN_CLI_BIN):
- make -C $(dir $@) $(notdir $@)
+$(if $(findstring src/,$(MAKECMDGOALS)),$(MAKECMDGOALS), none): FORCE
+ $(MAKE) -C src $(patsubst src/%,%,$@)
$(OSX_APP)/Contents/PkgInfo:
$(MKDIR_P) $(@D)