aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-08-04 17:35:33 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-08-06 19:29:19 -0400
commitd3434601baa8b2b8513ae08fcac99053860165ad (patch)
tree07ad31663bdcb2602bfc6eddce72d7b90f3c8dea /Makefile.am
parent206a7f9de6ad8fdd30ebc1a0cd812b891e005563 (diff)
downloadbitcoin-d3434601baa8b2b8513ae08fcac99053860165ad.tar.xz
build: Fix 'make deploy' when binaries haven't been built yet
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 63a22a2cc1..123a22525c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,6 +103,15 @@ if TARGET_WINDOWS
deploy: $(BITCOIN_WIN_INSTALLER)
endif
+$(BITCOIN_QT_BIN): FORCE
+ $(MAKE) -C src qt/$(@F)
+
+$(BITCOIND_BIN): FORCE
+ $(MAKE) -C src $(@F)
+
+$(BITCOIN_CLI_BIN): FORCE
+ $(MAKE) -C src $(@F)
+
if USE_LCOV
baseline.info: