aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2014-11-20 20:45:24 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2014-11-20 21:23:34 +0000
commiteef747bba81e66b2d551a3670a659bbe9dd4a8ce (patch)
tree925267c63dfc0ec438af55ecd0ff9ce7a0d04088 /Makefile.am
parent5c4dffd188bf82c1965871bdf013b18a61e3d7d0 (diff)
downloadbitcoin-eef747bba81e66b2d551a3670a659bbe9dd4a8ce.tar.xz
libbitcoinconsensus: Add pkg-config support
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6bc0044313..9b4d52c63c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,11 @@ SUBDIRS = src
GZIP_ENV="-9n"
+if BUILD_BITCOIN_LIBS
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libbitcoinconsensus.pc
+endif
+
BITCOIND_BIN=$(top_builddir)/src/bitcoind$(EXEEXT)
BITCOIN_QT_BIN=$(top_builddir)/src/qt/bitcoin-qt$(EXEEXT)
BITCOIN_CLI_BIN=$(top_builddir)/src/bitcoin-cli$(EXEEXT)