aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-12-19 18:03:47 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2014-12-19 18:05:04 +0100
commitcf875367d2be4754278214b89b0ecd7c108ba701 (patch)
tree1349b6593e6de0337dc7f8541eb1ebba7b025aa5 /Makefile.am
parentc63b47df1155ae623d83e9c9af89728092404435 (diff)
parenteef747bba81e66b2d551a3670a659bbe9dd4a8ce (diff)
downloadbitcoin-cf875367d2be4754278214b89b0ecd7c108ba701.tar.xz
Merge pull request #5334
eef747b libbitcoinconsensus: Add pkg-config support (Luke Dashjr)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b51f477b78..5649770602 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,11 @@ SUBDIRS = src
GZIP_ENV="-9n"
+if BUILD_BITCOIN_LIBS
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libbitcoinconsensus.pc
+endif
+
BITCOIND_BIN=$(top_builddir)/src/bitcoind$(EXEEXT)
BITCOIN_QT_BIN=$(top_builddir)/src/qt/bitcoin-qt$(EXEEXT)
BITCOIN_CLI_BIN=$(top_builddir)/src/bitcoin-cli$(EXEEXT)