aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatt Corallo <git@bluematt.me>2013-10-27 01:47:12 -0400
committerMatt Corallo <git@bluematt.me>2013-10-27 03:38:04 -0400
commit95fa14da69b6345f087991ceedcc34c73e66bab8 (patch)
tree43f22dd997c855ee3e734875060b16c82bb6c826 /Makefile.am
parentb33b9a6fefbe832bf45a6c7717d0537f27597bff (diff)
downloadbitcoin-95fa14da69b6345f087991ceedcc34c73e66bab8.tar.xz
Re-enable BitcoindComparisonTool:
* Use the latest version, with limited memory usage, and path to on-disk db (try mouting qa/tmp on a tmpfs)\ * enable -debug=net * re-enable BitcoindComparisonTool in pull-tester
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index dc0e6d8f76..e5bc9b99c6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,7 +118,8 @@ test_bitcoin_filtered.info: test_bitcoin.info
$(LCOV) -r $< "/usr/include/*" -o $@
block_test.info: test_bitcoin_filtered.info
- -@TIMEOUT=15 qa/pull-tester/run-bitcoind-for-test.sh $(JAVA) -Xmx2G -jar $(JAVA_COMPARISON_TOOL) 1 18444
+ $(MKDIR_P) qa/tmp
+ -@TIMEOUT=15 qa/pull-tester/run-bitcoind-for-test.sh $(JAVA) -jar $(JAVA_COMPARISON_TOOL) qa/tmp/compTool 1 18444
$(LCOV) -c -d $(abs_builddir)/src --t BitcoinJBlockTest -o $@
$(LCOV) -z -d $(abs_builddir)/src
$(LCOV) -z -d $(abs_builddir)/src/leveldb
@@ -146,7 +147,8 @@ endif
if USE_COMPARISON_TOOL
check-local:
- @qa/pull-tester/run-bitcoind-for-test.sh $(JAVA) -Xmx2G -jar $(JAVA_COMPARISON_TOOL) 1 18444
+ $(MKDIR_P) qa/tmp
+ @qa/pull-tester/run-bitcoind-for-test.sh $(JAVA) -jar $(JAVA_COMPARISON_TOOL) qa/tmp/compTool 1 18444
endif
EXTRA_DIST = $(top_srcdir)/share/genbuild.sh qa/pull-tester/pull-tester.sh $(WINDOWS_PACKAGING) $(OSX_PACKAGING)