aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-04-27 21:32:54 +0300
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-05-24 08:57:22 +0300
commite9f948c72790136656df6056fd9e3698f360e077 (patch)
tree5da941393b44b21f2579afd017565f3d1c56be83
parentc6d6bc8abb721be68a3d2cdba11ceb5e9814c9b1 (diff)
downloadbitcoin-e9f948c72790136656df6056fd9e3698f360e077.tar.xz
build: Convert warnings into errors when testing for -fstack-clash-protection
When building with Clang, if `-fstack-clash-protection` is used with an unsupported target, it may result in hundreds of `-Wunused-command-line-argument` warnings at compile time. This is currently the case when building for at least Darwin using Apple or LLVM Clang. Unsupported targets may also include *BSD, however that is changing; see further discussion in https://reviews.llvm.org/D92245 and https://reviews.freebsd.org/D27366. Note that this option is already skipped for Windows.
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d1707dfd64..c02b2f3cbe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -894,7 +894,7 @@ if test x$use_hardening != xno; then
dnl See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=90458 for more details.
;;
*)
- AX_CHECK_COMPILE_FLAG([-fstack-clash-protection],[HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fstack-clash-protection"])
+ AX_CHECK_COMPILE_FLAG([-fstack-clash-protection], [HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fstack-clash-protection"], [], [$CXXFLAG_WERROR])
;;
esac