aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2020-12-10 09:10:58 +0100
committerMarcoFalke <falke.marco@gmail.com>2020-12-10 09:11:04 +0100
commitc8fdbb46bd921575be84cf87e2966a455c3f5274 (patch)
tree742fb1879af20d5c6e12c609d2276646f0d8591e
parent38176dc66523881d45705fe8f96b9da76ec9981b (diff)
parent904d875cf5aecc337daa6a2243a803033cf4eee3 (diff)
Merge #20609: configure: output notice that test binary is disabled by fuzzing
904d875cf5aecc337daa6a2243a803033cf4eee3 configure: output notice that test binary is disabled by fuzzing (Andrew Poelstra) Pull request description: I wasted a bit of time today running a stale `test_bitcoin` and not understanding why, until I remembered that I'd ./configured my working directory with --enable-fuzz. Top commit has no ACKs. Tree-SHA512: 6cbe30547332114ad3fe61c67e224f5a28aac4b1b58e0acecb29cb04f5a34f792c927797aa8000449aae076435bd45acf209b7323b0b48fa971705d6ed3e6529
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 32d1138653..a956c10908 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1585,7 +1585,11 @@ AM_CONDITIONAL([ENABLE_ZMQ], [test "x$use_zmq" = "xyes"])
AC_MSG_CHECKING([whether to build test_bitcoin])
if test x$use_tests = xyes; then
- AC_MSG_RESULT([yes])
+ if test "x$enable_fuzz" = "xyes"; then
+ AC_MSG_RESULT([no, because fuzzing is enabled])
+ else
+ AC_MSG_RESULT([yes])
+ fi
BUILD_TEST="yes"
else
AC_MSG_RESULT([no])
@@ -1761,8 +1765,10 @@ if test x$bitcoin_enable_qt != xno; then
echo " with qr = $use_qr"
fi
echo " with zmq = $use_zmq"
-echo " with test = $use_tests"
-if test x$use_tests != xno; then
+if test x$enable_fuzz == xno; then
+ echo " with test = $use_tests"
+else
+ echo " with test = not building test_bitcoin because fuzzing is enabled"
echo " with fuzz = $enable_fuzz"
fi
echo " with bench = $use_bench"