aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. J. van der Laan <laanwj@protonmail.com>2021-05-18 21:44:50 +0200
committerW. J. van der Laan <laanwj@protonmail.com>2021-05-18 21:48:53 +0200
commit1da36b49ab63ff949bd64beea3af12d22e2d2187 (patch)
tree45653d04b28a71161dd6727721b52dcaff3d783a
parent741749a6159eb68dd8a3c5ef0d1701337931e6df (diff)
parent88bdc4d33eaeefb5cfe41bb4aa565c0cb361a982 (diff)
downloadbitcoin-1da36b49ab63ff949bd64beea3af12d22e2d2187.tar.xz
Merge bitcoin/bitcoin#21983: build: Silence lupdate "unknown namespace/class" warnings
88bdc4d33eaeefb5cfe41bb4aa565c0cb361a982 build: Silent lupdate "unknown namespace/class" warnings (Hennadii Stepanov) Pull request description: This PR removes multiple _"Qualifying with unknown namespace/class"_ warnings in `make -C src translate` output. Also all of the `lupdate` options are moved before input files (as documented). The remaining warnings are fixed in Qt 5.12.2 (see [QTBUG-42736](https://bugreports.qt.io/browse/QTBUG-42736)). ACKs for top commit: laanwj: Tested ACK 88bdc4d33eaeefb5cfe41bb4aa565c0cb361a982 Tree-SHA512: 9c12ff5425a84758aaf8073554891ffe7eb2d75650a12be14ece364b6b7a4461626654885e35c5543462f0941abb020cc36dc64e656c85c8d6d2da36efc7ea2c
-rw-r--r--src/Makefile.qt.include2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.qt.include b/src/Makefile.qt.include
index 74cf6734d6..30edb1e82d 100644
--- a/src/Makefile.qt.include
+++ b/src/Makefile.qt.include
@@ -358,7 +358,7 @@ $(srcdir)/qt/bitcoinstrings.cpp: FORCE
translate: $(srcdir)/qt/bitcoinstrings.cpp $(QT_FORMS_UI) $(QT_FORMS_UI) $(BITCOIN_QT_BASE_CPP) qt/bitcoin.cpp $(BITCOIN_QT_WINDOWS_CPP) $(BITCOIN_QT_WALLET_CPP) $(BITCOIN_QT_H) $(BITCOIN_MM)
@test -n $(LUPDATE) || echo "lupdate is required for updating translations"
- $(AM_V_GEN) QT_SELECT=$(QT_SELECT) $(LUPDATE) $^ -locations relative -no-obsolete -ts $(srcdir)/qt/locale/bitcoin_en.ts
+ $(AM_V_GEN) QT_SELECT=$(QT_SELECT) $(LUPDATE) -no-obsolete -I $(srcdir) -locations relative $^ -ts $(srcdir)/qt/locale/bitcoin_en.ts
@test -n $(LCONVERT) || echo "lconvert is required for updating translations"
$(AM_V_GEN) QT_SELECT=$(QT_SELECT) $(LCONVERT) -o $(srcdir)/qt/locale/bitcoin_en.xlf -i $(srcdir)/qt/locale/bitcoin_en.ts