From f44415360e7bdf1b7b90c0c4b08199518210f009 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jaime=20Marqui=CC=81nez=20Ferra=CC=81ndiz?=
 <jaime.marquinez.ferrandiz@gmail.com>
Date: Fri, 18 Oct 2013 13:49:25 +0200
Subject: Use the console_scripts entry point if setuptools is available

---
 setup.py | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

(limited to 'setup.py')

diff --git a/setup.py b/setup.py
index 3b6dc2d40..347a4f2d8 100644
--- a/setup.py
+++ b/setup.py
@@ -8,6 +8,7 @@ import sys
 
 try:
     from setuptools import setup
+    setuptools_available = True
 except ImportError:
     from distutils.core import setup
 
@@ -43,13 +44,16 @@ if len(sys.argv) >= 2 and sys.argv[1] == 'py2exe':
     params = py2exe_params
 else:
     params = {
-        'scripts': ['bin/youtube-dl'],
         'data_files': [  # Installing system-wide would require sudo...
             ('etc/bash_completion.d', ['youtube-dl.bash-completion']),
             ('share/doc/youtube_dl', ['README.txt']),
             ('share/man/man1/', ['youtube-dl.1'])
         ]
     }
+    if setuptools_available:
+        params['entry_points'] = {'console_scripts': ['youtube-dl = youtube_dl:main']}
+    else:
+        params['scripts'] = ['bin/youtube-dl']
 
 # Get the version from youtube_dl/version.py without importing the package
 exec(compile(open('youtube_dl/version.py').read(),
-- 
cgit v1.2.3