aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndres Mejia <amejia004@gmail.com>2012-04-18 08:36:39 -0700
committerAndres Mejia <amejia004@gmail.com>2012-04-18 08:36:39 -0700
commit81e874f3d20a027a844438b29f9dbcbc33d36737 (patch)
treecd4cadbf1b998875e2671e6ed12663d2450a6ad2 /configure.in
parentb95739e4fada671e2effaf180748492dae3edebf (diff)
parentc208cc9ff467f687c491241780ab275b6a14aa03 (diff)
Merge pull request #875 from aviksil/arm-fixes
Fixes to get XBMC building on ARM
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index fc82e55fde..b57a9d3afb 100755
--- a/configure.in
+++ b/configure.in
@@ -571,9 +571,9 @@ if test "$host_vendor" = "apple" ; then
LIBS="$LIBS -framework ApplicationServices"
fi
elif test "$use_arch" = "arm"; then
- CFLAGS="$CFLAGS -mfloat-abi=softfp -mno-apcs-stack-check"
- CXXFLAGS="$CXXFLAGS -mfloat-abi=softfp -mno-apcs-stack-check"
- FFMPEG_EXTRACFLAGS="-mfloat-abi=softfp"
+ CFLAGS="$CFLAGS -mno-apcs-stack-check"
+ CXXFLAGS="$CXXFLAGS -mno-apcs-stack-check"
+ FFMPEG_EXTRACFLAGS=""
if test "$use_tegra" = "yes"; then
# Compile for ARMv7a architecture, need to test gcc for vfpv3-d16 support
SAVE_CFLAGS="$CFLAGS"
@@ -588,9 +588,6 @@ elif test "$use_arch" = "arm"; then
CXXFLAGS="$CXXFLAGS -Wa,-march=armv6 -mtune=cortex-a8 -mthumb-interwork"
use_cpu=cortex-a8])
else
- # Compile for ARMv7a architecture, CortexA8 cpu and check for enabled NEON coprocessor
- CFLAGS="$CFLAGS -Wa,-march=armv7a -mcpu=cortex-a8"
- CXXFLAGS="$CXXFLAGS -Wa,-march=armv7a -mcpu=cortex-a8"
if test "$use_neon" = "yes"; then
CFLAGS="$CFLAGS -mfpu=neon -mvectorize-with-neon-quad"
CXXFLAGS="$CXXFLAGS -mfpu=neon -mvectorize-with-neon-quad"