aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorelupus <elupus@svn>2010-04-06 13:28:16 +0000
committerelupus <elupus@svn>2010-04-06 13:28:16 +0000
commit805f8e6b7a11884be421b8f7abc8a19cbf651064 (patch)
tree8fadfd536123c8d2c057e80d14c85421bb1c496c /configure.in
parent7cbaa8673ab13021249890340ce03b7813ff4b49 (diff)
added: check for vaapi at configure time
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@29044 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 95f14db5d6..3918173b56 100644
--- a/configure.in
+++ b/configure.in
@@ -33,6 +33,8 @@ avahi_not_found="== Could not find libavahi-common or libavahi-client. Avahi sup
avahi_disabled="== Avahi support disabled. =="
vdpau_not_found="== Could not find libvdpau. VDPAU support disabled. =="
vdpau_disabled="== VDPAU support manually disabled. =="
+vdpau_not_found="== Could not find libva. VAAPI support disabled. =="
+vdpau_disabled="== VAAPI support manually disabled. =="
crystalhd_not_found="== Could not find libldil. CrystalHD support disabled. =="
crystalhd_disabled="== CrystalHD support manually disabled. =="
ssh_not_found="== Could not find libssh. SSH FTP VFS support disabled. =="
@@ -122,6 +124,12 @@ AC_ARG_ENABLE([vdpau],
[use_vdpau=$enableval],
[use_vdpau=yes])
+AC_ARG_ENABLE([vaapi],
+ [AS_HELP_STRING([--enable-vaapi],
+ [enable VAAPI decoding (default is yes)])],
+ [use_vaapi=$enableval],
+ [use_vaapi=yes])
+
AC_ARG_ENABLE([crystalhd],
[AS_HELP_STRING([--enable-crystalhd],
[enable CrystalHD decoding (default is yes)])],
@@ -675,6 +683,19 @@ else
fi
fi
+# VAAPI
+if test "$host_vendor" = "apple" ; then
+ use_vaapi="no"
+ AC_MSG_NOTICE($vaapi_disabled)
+else
+ if test "$use_vaapi" = "yes"; then
+ AC_CHECK_HEADER([va/va.h],AC_DEFINE([HAVE_LIBVA], [], [Define to 1 if you have the 'vaapi' library (-lva).]),
+ use_vaapi=no;AC_MSG_RESULT($vaapi_not_found))
+ else
+ AC_MSG_NOTICE($vaapi_disabled)
+ fi
+fi
+
# CrystalHD
if test "$use_crystalhd" = "yes"; then
AC_CHECK_HEADER([libcrystalhd/libcrystalhd_if.h],AC_DEFINE([HAVE_LIBCRYSTALHD], [],
@@ -837,6 +858,12 @@ else
final_message="$final_message\n VDPAU:\tNo"
fi
+if test "$use_vaapi" = "yes"; then
+ final_message="$final_message\n VAAPI:\tYes"
+else
+ final_message="$final_message\n VAAPI:\tNo"
+fi
+
if test "$use_crystalhd" = "yes"; then
final_message="$final_message\n CrystalHD:\tYes"
else
@@ -1256,6 +1283,7 @@ XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/ffmpeg], [
--enable-postproc \
--enable-gpl \
`if test "$use_vdpau" = "yes"; then echo --enable-vdpau; else echo --disable-vdpau; fi` \
+ `if test "$use_vaapi" = "yes"; then echo --enable-vaapi; else echo --disable-vaapi; fi` \
--enable-libfaad \
--enable-protocol=http \
--enable-pthreads \