aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorArne Morten Kvarving <spiff@xbmc.org>2012-10-07 12:42:03 -0700
committerArne Morten Kvarving <spiff@xbmc.org>2012-10-07 12:42:03 -0700
commit7cd7792994fd5e0f59e90f0a86e170dac4a31538 (patch)
tree043834c9cb29b346fbc318c0609f993f58dc1733 /configure.in
parent489d206ea438c9f5fb7d6ad3c4e27afb32cb4ca8 (diff)
parent882aa1e13fe281094ccc94fa312b8ce729bef8ff (diff)
Merge pull request #1316 from wsnipex/master
configure switch for ssh support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3327487f72..ef5c116758 100644
--- a/configure.in
+++ b/configure.in
@@ -130,7 +130,8 @@ vtbdecoder_enabled="== VTBDecoder support enabled. =="
vtbdecoder_disabled="== VTBDecoder support manually disabled. =="
openmax_disabled="== OpenMax support manually disabled. =="
openmax_not_found="== Could not find libnvomx. OpenMax support disabled. =="
-ssh_not_found="== Could not find libssh. SSH FTP VFS support disabled. =="
+ssh_not_found="== Could not find libssh. =="
+ssh_disabled="== SSH SFTP disabled. =="
librtmp_not_found="== Could not find libRTMP. RTMP support disabled. =="
librtmp_disabled="== RTMP support disabled. =="
libnfs_not_found="== Could not find libnfs. NFS client support disabled. =="
@@ -331,6 +332,12 @@ AC_ARG_ENABLE([pulse],
[use_pulse=$enableval],
[use_pulse=no])
+AC_ARG_ENABLE([ssh],
+ [AS_HELP_STRING([--disable-ssh],
+ [enable SSH SFTP support (default is enabled)])],
+ [use_ssh=$enableval],
+ [use_ssh=yes])
+
AC_ARG_ENABLE([rtmp],
[AS_HELP_STRING([--enable-rtmp],
[enable RTMP support via librtmp (default is auto)])],
@@ -931,7 +938,6 @@ AC_CHECK_LIB([ssl], [main],, AC_MSG_ERROR($missing_library))
if test "$use_mysql" = "yes"; then
AC_CHECK_LIB([mysqlclient], [main],, AC_MSG_ERROR($missing_library))
fi
-AC_CHECK_LIB([ssh], [sftp_tell64],, AC_MSG_RESULT([Could not find suitable version of libssh]))
AC_CHECK_LIB([bluetooth], [hci_devid],, AC_MSG_RESULT([Could not find suitable version of libbluetooth]))
AC_CHECK_LIB([yajl], [main],, AC_MSG_ERROR($missing_library))
AC_CHECK_LIB([tinyxml], [main],, AC_MSG_ERROR($missing_library))
@@ -1242,6 +1248,14 @@ else
USE_SKIN_TOUCHED=0
fi
+# libssh
+if test "x$use_ssh" = "xno"; then
+ AC_MSG_NOTICE($ssh_disabled)
+ use_libssh="no"
+else
+ AC_CHECK_LIB([ssh], [sftp_tell64],, AC_MSG_ERROR($ssh_not_found))
+ AC_DEFINE([HAVE_LIBSSH], [1], [Whether to use libSSH library.])
+fi
# libRTMP
if test "$use_librtmp" != "no"; then
@@ -2144,6 +2158,12 @@ else
USE_WEB_SERVER=0
fi
+if test "$use_libssh" != "no"; then
+ final_message="$final_message\n libssh support:\tYes"
+else
+ final_message="$final_message\n libssh support:\tNo"
+fi
+
if test "$use_librtmp" != "no"; then
final_message="$final_message\n libRTMP support:\tYes"
else