aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlasdair Campbell <alcoheca@gmail.com>2012-08-03 11:49:52 +0100
committerAlasdair Campbell <alcoheca@gmail.com>2012-09-07 19:20:21 +0100
commit3b6b078e4ddbf343b2b47ff087708f6c2fe2e711 (patch)
treef3d22e9d137f3455824cd628d5315de39ee0c777 /configure.in
parent47f3f67eaa6431603ee0133042d6ff2d4d6a2907 (diff)
[UPnP] changed: make UPnP optional (enabled by default), fix some missing #ifdef HAS_UPNP guards
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fdcef0e05e..e8cc72b979 100644
--- a/configure.in
+++ b/configure.in
@@ -367,6 +367,12 @@ AC_ARG_ENABLE([airtunes],
[use_airtunes=$enableval],
[use_airtunes=auto])
+AC_ARG_ENABLE([upnp],
+ [AS_HELP_STRING([--disable-upnp],
+ [disable UPnP support (default is enabled)])],
+ [use_upnp=$enableval],
+ [use_upnp=yes])
+
AC_ARG_ENABLE([ffmpeg_libvorbis],
[AS_HELP_STRING([--enable-ffmpeg-libvorbis],
[enable FFmpeg vorbis encoding (default is no)])],
@@ -2134,6 +2140,15 @@ else
final_message="$final_message\n AirTunes support:\tNo"
fi
+if test "x$use_upnp" != "xno"; then
+ final_message="$final_message\n UPnP support:\t\tYes"
+ USE_UPNP=1
+ AC_DEFINE([USE_UPNP], [1], [Define to 1 to enable UPnP support.])
+else
+ USE_UPNP=0
+ final_message="$final_message\n UPnP support:\t\tNo"
+fi
+
if test "$use_optical_drive" = "yes"; then
final_message="$final_message\n Optical drive:\tYes"
else
@@ -2244,6 +2259,7 @@ OUTPUT_FILES="Makefile \
xbmc/guilib/Makefile \
xbmc/interfaces/Makefile \
xbmc/network/Makefile \
+ xbmc/network/upnp/Makefile \
lib/libRTV/Makefile \
lib/libexif/Makefile \
lib/libXDAAP/Makefile \
@@ -2342,6 +2358,7 @@ AC_SUBST(USE_LIBCEC)
AC_SUBST(USE_CEC_RPI_API)
AC_SUBST(USE_MYSQL)
AC_SUBST(USE_WEB_SERVER)
+AC_SUBST(USE_UPNP)
AC_SUBST(USE_ANDROID)
AC_SUBST(GTEST_CONFIGURED)