aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-01 16:45:46 -0400
committerAlexis Ballier <aballier@gentoo.org>2013-08-06 10:13:48 -0400
commitcf4a312c186e064d0374152b06d093acb3b9c590 (patch)
tree2174c8f5fa48ee0d72d904f5aacd76f38560b138 /configure.in
parent457a7e8e9daa00230cdc579a62f58cb5be52f973 (diff)
configure, external ffmpeg: Drop check for libavresample.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index d63d13dc21..beee62df03 100644
--- a/configure.in
+++ b/configure.in
@@ -1619,14 +1619,7 @@ fi
# External FFmpeg
if test "$use_external_ffmpeg" = "yes"; then
- FFMPEG_LIBNAMES="libavcodec libavfilter libavformat libavutil libpostproc libswscale"
-
- # one of libswresample or libavresample is needed
- PKG_CHECK_EXISTS([libswresample], FFMPEG_LIBNAMES="$FFMPEG_LIBNAMES libswresample",
- [PKG_CHECK_EXISTS([libavresample],
- FFMPEG_LIBNAMES="$FFMPEG_LIBNAMES libavresample",
- AC_MSG_ERROR([You need either libswresample
- or libavresample.]))])
+ FFMPEG_LIBNAMES="libavcodec libavfilter libavformat libavutil libpostproc libswscale libswresample"
PKG_CHECK_MODULES([FFMPEG], [$FFMPEG_LIBNAMES],
[INCLUDES="$INCLUDES $FFMPEG_CFLAGS"; LIBS="$LIBS $FFMPEG_LIBS"],
@@ -1639,9 +1632,6 @@ if test "$use_external_ffmpeg" = "yes"; then
AC_CHECK_HEADERS([libavcodec/avcodec.h libavfilter/avfilter.h libavformat/avformat.h libavutil/avutil.h libpostproc/postprocess.h libswscale/swscale.h],,
[AC_MSG_ERROR($missing_headers)])
- # Check for libswresample or libavresample headers.
- AC_CHECK_HEADERS([libswresample/swresample.h libavresample/avresample.h])
-
AC_MSG_NOTICE($external_ffmpeg_enabled)
USE_EXTERNAL_FFMPEG=1
AC_DEFINE([USE_EXTERNAL_FFMPEG], [1], [Whether to use external FFmpeg libraries.])