aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartijn Kaijser <machine.sanctum@gmail.com>2014-10-03 21:40:44 +0200
committerMartijn Kaijser <machine.sanctum@gmail.com>2014-10-03 21:40:44 +0200
commit77f09394dfedcc3f15d49a6024b4ba9912a9c1eb (patch)
tree63c1d4f8c6bc58c20ac3414876f43d3ea2228fb8 /configure.in
parent59bd84ca7fc56fb63d7f372c70664b9059083353 (diff)
parent3a9e558d0ca886838b2c358e43ac53d9192bdc08 (diff)
Merge pull request #5354 from popcornmix/mmal_acceleration
[mmal] Add MMAL decoder and MMAL renderer for Raspberry Pi
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f5ebd0b58d..a0ae4c6b00 100644
--- a/configure.in
+++ b/configure.in
@@ -721,6 +721,7 @@ case $use_platform in
ARCH="arm"
AC_DEFINE(HAS_EGLGLES, [1], [Define if supporting EGL based GLES Framebuffer])
USE_OMXLIB=1; AC_DEFINE([HAVE_OMXLIB],[1],["Define to 1 if OMX libs is enabled"])
+ USE_MMAL=1; AC_DEFINE([HAS_MMAL],[1],["Define to 1 if MMAL libs is enabled"])
CFLAGS="$CFLAGS"
CXXFLAGS="$CXXFLAGS"
;;
@@ -1010,7 +1011,7 @@ if test "$use_gles" = "yes"; then
AC_DEFINE([HAVE_LIBEGL],[1],["Define to 1 if you have the `EGL' library (-lEGL)."])
AC_DEFINE([HAVE_LIBGLESV2],[1],["Define to 1 if you have the `GLESv2' library (-lGLESv2)."])
AC_MSG_RESULT(== WARNING: OpenGLES support is assumed.)
- LIBS="$LIBS -lEGL -lGLESv2 -lbcm_host -lvcos -lvchiq_arm"
+ LIBS="$LIBS -lEGL -lGLESv2 -lbcm_host -lvcos -lvchiq_arm -lmmal -lmmal_core -lmmal_util"
else
AC_CHECK_LIB([EGL], [main],, AC_MSG_ERROR($missing_library))
AC_CHECK_LIB([GLESv2],[main],, AC_MSG_ERROR($missing_library))
@@ -2585,6 +2586,7 @@ AC_SUBST(USE_DOXYGEN)
AC_SUBST(USE_PVR_ADDONS)
AC_SUBST(UPNP_DEFINES)
AC_SUBST(USE_SSE4)
+AC_SUBST(USE_MMAL)
# pushd and popd are not available in other shells besides bash, so implement
# our own pushd/popd functions