aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2014-04-17 15:18:07 +0200
committerRainer Hochecker <fernetmenta@online.de>2014-04-27 18:05:13 +0200
commit4982f25c91c2963a8f05bef86904dc5ab0f5f380 (patch)
tree2feb2ef33035893398033471df7b292a6be02ec4 /configure.in
parent9d6a9f115f31315c55aad7d01d37a4150e69e8a1 (diff)
[linux] log how ffmpeg was linked, ffmpeg version check and logging
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index df956b2a54..3fcb178be8 100644
--- a/configure.in
+++ b/configure.in
@@ -1714,6 +1714,10 @@ FFMPEG_LIBNAMES="libavcodec >= 55.39.101
libswscale >= 2.5.101
libswresample >= 0.17.104"
+ffmpeg_build="${abs_top_srcdir}/tools/depends/target/ffmpeg"
+FFMPEG_VER_SHA=$(grep "VERSION=" ${ffmpeg_build}/FFMPEG-VERSION | sed 's/VERSION=//g')
+AC_DEFINE_UNQUOTED([FFMPEG_VER_SHA], ["$FFMPEG_VER_SHA"], [FFmpeg version hash])
+
if test "$with_ffmpeg" = "shared"; then
# allow linking against shared ffmpeg libs
# a proper version must be installed, we won't build ffmpeg
@@ -1734,7 +1738,6 @@ if test "${USE_STATIC_FFMPEG}" = "1"; then
fi
if test "$cross_compiling" != "yes"; then
- ffmpeg_build="${abs_top_srcdir}/tools/depends/target/ffmpeg"
if test "$use_debug" != "yes"; then
FFMPEG_OPTS="-r"
fi