aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@kodi.tv>2022-06-14 21:04:50 +1000
committerfuzzard <fuzzard@kodi.tv>2022-06-17 22:22:43 +1000
commit3db88ec9aa0027e5b874d761ae207845938876ce (patch)
tree1fbfdf6f9d02433796c55557d86c4c3a10c47ab6 /CMakeLists.txt
parentf68818df375e875f93d05adbb2422b8eb8697f1b (diff)
[cmake] split flatbuffers buildtool (flatc) and target headers find modules
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48ad59a81d..ba1fa9ce28 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,6 +62,7 @@ option(ENABLE_INTERNAL_CROSSGUID "Enable internal crossguid?" ON)
# use ffmpeg from depends or system
option(ENABLE_INTERNAL_FFMPEG "Enable internal ffmpeg?" OFF)
option(ENABLE_INTERNAL_RapidJSON "Enable internal rapidjson?" ON)
+cmake_dependent_option(ENABLE_INTERNAL_FLATBUFFERS "Enable internal flatbuffers?" OFF "DEFINED USE_INTERNAL_LIBS;NOT USE_INTERNAL_LIBS" ON)
cmake_dependent_option(ENABLE_INTERNAL_TAGLIB "Enable internal taglib?" OFF "DEFINED USE_INTERNAL_LIBS;NOT USE_INTERNAL_LIBS" ON)
# Internal Depends - supported on UNIX platforms
@@ -69,7 +70,6 @@ if(UNIX)
option(FFMPEG_PATH "Path to external ffmpeg?" "")
option(ENABLE_INTERNAL_FMT "Enable internal fmt?" OFF)
option(ENABLE_INTERNAL_FSTRCMP "Enable internal fstrcmp?" OFF)
- option(ENABLE_INTERNAL_FLATBUFFERS "Enable internal flatbuffers?" OFF)
option(ENABLE_INTERNAL_DAV1D "Enable internal dav1d?" OFF)
option(ENABLE_INTERNAL_GTEST "Enable internal gtest?" OFF)
option(ENABLE_INTERNAL_UDFREAD "Enable internal udfread?" OFF)
@@ -138,7 +138,8 @@ foreach(depspec ${PLATFORM_REQUIRED_DEPS})
endforeach()
# Required tools. Keep in alphabetical order please
-set(required_buildtools JsonSchemaBuilder
+set(required_buildtools FlatC
+ JsonSchemaBuilder
TexturePacker
)