aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRechi <Rechi@users.noreply.github.com>2020-10-05 01:48:47 +0200
committerRechi <Rechi@users.noreply.github.com>2020-10-05 01:48:47 +0200
commitcc69cc21e609216cec13b56f5dcfab2e0fcf1c63 (patch)
tree12e293157a95d84f214faaef711f13e602ac8862 /CMakeLists.txt
parent2b0753e10408c1a2b2607c40b3f1d46f0bcc33dd (diff)
[cmake] add include-what-you-use support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5cb79d62a..019854b680 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,7 @@ option(VERBOSE "Enable verbose output?" OFF)
option(ENABLE_CLANGTIDY "Enable clang-tidy support?" OFF)
option(ENABLE_CPPCHECK "Enable cppcheck support?" OFF)
option(ENABLE_DVDCSS "Enable libdvdcss support?" ON)
+option(ENABLE_INCLUDEWHATYOUUSE "Enable include-what-you-use support?" OFF)
option(ENABLE_UPNP "Enable UPnP support?" ON)
option(ENABLE_AIRTUNES "Enable AirTunes support?" ON)
option(ENABLE_OPTICAL "Enable optical support?" ON)
@@ -152,6 +153,7 @@ set(optional_deps Alsa
Cppcheck
Dav1d
DBus
+ IncludeWhatYouUse
Iso9660pp
LCMS2
LircClient