From 097c290238caa4d92bf9222af17f64b946fa7349 Mon Sep 17 00:00:00 2001
From: larryhaja <larryhaja@gmail.com>
Date: Sun, 16 Sep 2012 21:36:19 -0700
Subject: python/netifaces: Added (python module for querying network
 interfaces)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
---
 python/netifaces/README               |  1 +
 python/netifaces/netifaces.SlackBuild | 53 +++++++++++++++++++++++++++++++++++
 python/netifaces/netifaces.info       | 10 +++++++
 python/netifaces/slack-desc           | 19 +++++++++++++
 4 files changed, 83 insertions(+)
 create mode 100644 python/netifaces/README
 create mode 100644 python/netifaces/netifaces.SlackBuild
 create mode 100644 python/netifaces/netifaces.info
 create mode 100644 python/netifaces/slack-desc

(limited to 'python')

diff --git a/python/netifaces/README b/python/netifaces/README
new file mode 100644
index 0000000000000..008cffeaebdca
--- /dev/null
+++ b/python/netifaces/README
@@ -0,0 +1 @@
+Portable module to access network interface information in Python.
diff --git a/python/netifaces/netifaces.SlackBuild b/python/netifaces/netifaces.SlackBuild
new file mode 100644
index 0000000000000..a8c33a46502ea
--- /dev/null
+++ b/python/netifaces/netifaces.SlackBuild
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+# Slackware build script for netifaces
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=netifaces
+VERSION=${VERSION:-0.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i486 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/netifaces/netifaces.info b/python/netifaces/netifaces.info
new file mode 100644
index 0000000000000..49d6f17876ef2
--- /dev/null
+++ b/python/netifaces/netifaces.info
@@ -0,0 +1,10 @@
+PRGNAM="netifaces"
+VERSION="0.8"
+HOMEPAGE="http://alastairs-place.net/projects/netifaces/"
+DOWNLOAD="http://alastairs-place.net/projects/netifaces/netifaces-0.8.tar.gz"
+MD5SUM="e57e5983f4c286fac5f8068fbfc5c873"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="distribute"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/netifaces/slack-desc b/python/netifaces/slack-desc
new file mode 100644
index 0000000000000..8e34e2b6b793b
--- /dev/null
+++ b/python/netifaces/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.  Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in.  You must
+# make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+         |-----handy-ruler------------------------------------------------------|
+netifaces: netifaces
+netifaces: 
+netifaces: Portable module to access network interface information in Python.
+netifaces: 
+netifaces: Homepage: http://alastairs-place.net/projects/netifaces/
+netifaces:
+netifaces:
+netifaces:
+netifaces:
+netifaces:
+netifaces:
-- 
cgit v1.2.3