From 27ab275f39ef8b35a329c57c8daccb357ea1907d Mon Sep 17 00:00:00 2001
From: fourtysixandtwo <fourtysixandtwo@sliderr.net>
Date: Sun, 31 Mar 2024 11:33:43 -0600
Subject: python/python3-constantly: Fix PYTHONPATH.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
---
 python/python3-constantly/python3-constantly.SlackBuild | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

(limited to 'python/python3-constantly')

diff --git a/python/python3-constantly/python3-constantly.SlackBuild b/python/python3-constantly/python3-constantly.SlackBuild
index f47f43efa0e23..afe1ebf380c33 100644
--- a/python/python3-constantly/python3-constantly.SlackBuild
+++ b/python/python3-constantly/python3-constantly.SlackBuild
@@ -85,7 +85,8 @@ find -L . \
  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
 
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
 python3 setup.py install --root=$PKG
 
 find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
-- 
cgit v1.2.3