From a472b1fea6dce06d3aee9f5b027ee0582cd51bf9 Mon Sep 17 00:00:00 2001
From: pyllyukko <pyllyukko@maimed.org>
Date: Wed, 14 Jun 2023 20:05:02 +0300
Subject: ham/hackrf: Updated for version 2023.01.1, moved from development.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
---
 development/hackrf/README            |   9 ---
 development/hackrf/hackrf.SlackBuild | 115 ----------------------------------
 development/hackrf/hackrf.info       |  10 ---
 development/hackrf/slack-desc        |  19 ------
 ham/hackrf/README                    |   9 +++
 ham/hackrf/hackrf.SlackBuild         | 116 +++++++++++++++++++++++++++++++++++
 ham/hackrf/hackrf.info               |  10 +++
 ham/hackrf/slack-desc                |  19 ++++++
 8 files changed, 154 insertions(+), 153 deletions(-)
 delete mode 100644 development/hackrf/README
 delete mode 100644 development/hackrf/hackrf.SlackBuild
 delete mode 100644 development/hackrf/hackrf.info
 delete mode 100644 development/hackrf/slack-desc
 create mode 100644 ham/hackrf/README
 create mode 100644 ham/hackrf/hackrf.SlackBuild
 create mode 100644 ham/hackrf/hackrf.info
 create mode 100644 ham/hackrf/slack-desc

diff --git a/development/hackrf/README b/development/hackrf/README
deleted file mode 100644
index 6f721559b18d7..0000000000000
--- a/development/hackrf/README
+++ /dev/null
@@ -1,9 +0,0 @@
-This is the host software for hackrf, a project to produce
-a low cost, open source software radio platform.
-
-Below are some paramaters that can be passed to the slackbuild
-to turn on some optional components.
-
-RULES=yes|no (Default is no) In order to be able to use the
-dongle as a non-root user, you may install the appropriate
-udev rules
diff --git a/development/hackrf/hackrf.SlackBuild b/development/hackrf/hackrf.SlackBuild
deleted file mode 100644
index efd926884c0a6..0000000000000
--- a/development/hackrf/hackrf.SlackBuild
+++ /dev/null
@@ -1,115 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for hackrf
-
-# Copyright 2015-2018 Panagiotis Nikolaou, Culver City, CA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-#    notice, this list of conditions and the following disclaimer.
-#
-#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
-#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=hackrf
-VERSION=${VERSION:-20180430}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
-  case "$( uname -m )" in
-    i?86) ARCH=i586 ;;
-    arm*) ARCH=arm ;;
-       *) ARCH=$( uname -m ) ;;
-  esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
-  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
-  exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
-  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
-     SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-     LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
-     SLKCFLAGS="-O2 -fPIC"
-     LIBDIRSUFFIX="64"
-else
-     SLKCFLAGS="-O2"
-     LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-
-# Use the dongle as a non-root user.
-if [ "${RULES:-no}" == "yes" ]; then
-	OPT1="$OPT -DINSTALL_UDEV_RULES=ON"
-fi
-
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-cd host
-sed -i "s|lib/pkgconfig|lib${LIBDIRSUFFIX}/pkgconfig|" libhackrf/CMakeLists.txt
-mkdir -p build
-cd build
-  cmake \
- 	-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-	-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-	-DCMAKE_INSTALL_PREFIX=/usr \
-        $OPT1 \
-        -DCMAKE_BUILD_TYPE=Release \
-        -DLIB_SUFFIX=$LIBDIRSUFFIX ..
-  make
-make install DESTDIR=$PKG
-cd ../..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
-  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a TRADEMARK COPYING $PKG/usr/doc/$PRGNAM-$VERSION
-
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/hackrf/hackrf.info b/development/hackrf/hackrf.info
deleted file mode 100644
index 6dea81c261b65..0000000000000
--- a/development/hackrf/hackrf.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="hackrf"
-VERSION="20180430"
-HOMEPAGE="https://github.com/mossmann/hackrf"
-DOWNLOAD="https://master.dl.sourceforge.net/project/slackbuildsdirectlinks/hackrf/hackrf-20180430.tar.bz2"
-MD5SUM="dac360dca7f0e6896aaa4b7ba34af3a6"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Panagiotis Nikolaou"
-EMAIL="hostmaster@slackonly.com"
diff --git a/development/hackrf/slack-desc b/development/hackrf/slack-desc
deleted file mode 100644
index b34786fed01ee..0000000000000
--- a/development/hackrf/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct.  It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
-      |-----handy-ruler------------------------------------------------------|
-hackrf: hackrf (radio platform)
-hackrf:
-hackrf: HackRF, a project to produce a low cost, open source software
-hackrf: radio platform.
-hackrf:
-hackrf: homepage: https://github.com/mossmann/hackrf
-hackrf:
-hackrf:
-hackrf:
-hackrf:
-hackrf:
diff --git a/ham/hackrf/README b/ham/hackrf/README
new file mode 100644
index 0000000000000..6f721559b18d7
--- /dev/null
+++ b/ham/hackrf/README
@@ -0,0 +1,9 @@
+This is the host software for hackrf, a project to produce
+a low cost, open source software radio platform.
+
+Below are some paramaters that can be passed to the slackbuild
+to turn on some optional components.
+
+RULES=yes|no (Default is no) In order to be able to use the
+dongle as a non-root user, you may install the appropriate
+udev rules
diff --git a/ham/hackrf/hackrf.SlackBuild b/ham/hackrf/hackrf.SlackBuild
new file mode 100644
index 0000000000000..f2d8236298a84
--- /dev/null
+++ b/ham/hackrf/hackrf.SlackBuild
@@ -0,0 +1,116 @@
+#!/bin/bash
+
+# Slackware build script for hackrf
+
+# Copyright 2015-2018 Panagiotis Nikolaou, Culver City, CA
+# Copyright 2023 pyllyukko
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
+#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=hackrf
+VERSION=${VERSION:-2023.01.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i586 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+  exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+     SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+     LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+     SLKCFLAGS="-O2 -fPIC"
+     LIBDIRSUFFIX="64"
+else
+     SLKCFLAGS="-O2"
+     LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+
+# Use the dongle as a non-root user.
+if [ "${RULES:-no}" == "yes" ]; then
+	OPT1="$OPT -DINSTALL_UDEV_RULES=ON"
+fi
+
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cd host
+sed -i "s|lib/pkgconfig|lib${LIBDIRSUFFIX}/pkgconfig|" libhackrf/CMakeLists.txt
+mkdir -p build
+cd build
+  cmake \
+ 	-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+	-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+	-DCMAKE_INSTALL_PREFIX=/usr \
+        $OPT1 \
+        -DCMAKE_BUILD_TYPE=Release \
+        -DLIB_SUFFIX=$LIBDIRSUFFIX ..
+  make
+make install DESTDIR=$PKG
+cd ../..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CODE_OF_CONDUCT.md RELEASENOTES Readme.md COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/ham/hackrf/hackrf.info b/ham/hackrf/hackrf.info
new file mode 100644
index 0000000000000..a9deb19f8a7ff
--- /dev/null
+++ b/ham/hackrf/hackrf.info
@@ -0,0 +1,10 @@
+PRGNAM="hackrf"
+VERSION="2023.01.1"
+HOMEPAGE="https://github.com/mossmann/hackrf"
+DOWNLOAD="https://github.com/greatscottgadgets/hackrf/releases/download/v2023.01.1/hackrf-2023.01.1.tar.xz"
+MD5SUM="3f681b74fd1629c859a08b1946453fcd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="pyllyukko"
+EMAIL="pyllyukko@maimed.org"
diff --git a/ham/hackrf/slack-desc b/ham/hackrf/slack-desc
new file mode 100644
index 0000000000000..b34786fed01ee
--- /dev/null
+++ b/ham/hackrf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+      |-----handy-ruler------------------------------------------------------|
+hackrf: hackrf (radio platform)
+hackrf:
+hackrf: HackRF, a project to produce a low cost, open source software
+hackrf: radio platform.
+hackrf:
+hackrf: homepage: https://github.com/mossmann/hackrf
+hackrf:
+hackrf:
+hackrf:
+hackrf:
+hackrf:
-- 
cgit v1.2.3