From 67ab739de327104a32548f379157222cc5c8c294 Mon Sep 17 00:00:00 2001
From: Thibaut Notteboom <thibaut.notteboom@gmail.com>
Date: Thu, 2 Jul 2015 22:49:09 +0700
Subject: system/facter: Updated for version 3.0.1 (moved from ruby).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
---
 ruby/facter/README               |   4 --
 ruby/facter/doinst.sh            |  14 ------
 ruby/facter/facter.SlackBuild    |  92 ----------------------------------
 ruby/facter/facter.info          |  10 ----
 ruby/facter/slack-desc           |  19 -------
 system/facter/README             |   4 ++
 system/facter/doinst.sh          |  14 ++++++
 system/facter/facter-lib64.patch |  11 ++++
 system/facter/facter.SlackBuild  | 105 +++++++++++++++++++++++++++++++++++++++
 system/facter/facter.info        |  10 ++++
 system/facter/slack-desc         |  19 +++++++
 11 files changed, 163 insertions(+), 139 deletions(-)
 delete mode 100644 ruby/facter/README
 delete mode 100644 ruby/facter/doinst.sh
 delete mode 100644 ruby/facter/facter.SlackBuild
 delete mode 100644 ruby/facter/facter.info
 delete mode 100644 ruby/facter/slack-desc
 create mode 100644 system/facter/README
 create mode 100644 system/facter/doinst.sh
 create mode 100644 system/facter/facter-lib64.patch
 create mode 100644 system/facter/facter.SlackBuild
 create mode 100644 system/facter/facter.info
 create mode 100644 system/facter/slack-desc

diff --git a/ruby/facter/README b/ruby/facter/README
deleted file mode 100644
index d1c815947db85..0000000000000
--- a/ruby/facter/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Facter is a lightweight program that gathers basic node information
-about the hardware and operating system. Facter is especially useful
-for retrieving things like operating system names, hardware
-characteristics, IP addresses, MAC addresses, and SSH keys.
diff --git a/ruby/facter/doinst.sh b/ruby/facter/doinst.sh
deleted file mode 100644
index 65ce6d65a5457..0000000000000
--- a/ruby/facter/doinst.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-config() {
-  NEW="$1"
-  OLD="$(dirname $NEW)/$(basename $NEW .new)"
-  # If there's no config file by that name, mv it over:
-  if [ ! -r $OLD ]; then
-    mv $NEW $OLD
-  elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
-    # toss the redundant copy
-    rm $NEW
-  fi
-  # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-config etc/facter.conf.new
diff --git a/ruby/facter/facter.SlackBuild b/ruby/facter/facter.SlackBuild
deleted file mode 100644
index 9fbdda570ef39..0000000000000
--- a/ruby/facter/facter.SlackBuild
+++ /dev/null
@@ -1,92 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for facter
-
-# Copyright 2012-2013 Thibaut Notteboom, Paris, FRANCE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-#    notice, this list of conditions and the following disclaimer.
-#
-#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
-#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=facter
-VERSION=${VERSION:-1.6.17}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
-  case "$( uname -m )" in
-    i?86) ARCH=i486 ;;
-    arm*) ARCH=arm ;;
-       *) ARCH=$( uname -m ) ;;
-  esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
-  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
-  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
-  SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
-else
-  SLKCFLAGS="-O2"
-  LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-ruby install.rb install --destdir=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
-  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/etc
-cp -a etc/facter.conf $PKG/etc/facter.conf.new
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CONTRIBUTING.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/ruby/facter/facter.info b/ruby/facter/facter.info
deleted file mode 100644
index f09e1843dbdd1..0000000000000
--- a/ruby/facter/facter.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="facter"
-VERSION="1.6.17"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-DOWNLOAD="http://puppetlabs.com/downloads/facter/facter-1.6.17.tar.gz"
-MD5SUM="7dbefba6148d2c6b6034009c46b3ae14"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Thibaut Notteboom"
-EMAIL="tib@tibux.org"
diff --git a/ruby/facter/slack-desc b/ruby/facter/slack-desc
deleted file mode 100644
index 4107441ae3360..0000000000000
--- a/ruby/facter/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct.  It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
-      |-----handy-ruler------------------------------------------------------|
-facter: Facter (Ruby module for collecting facts about a host OS)
-facter:
-facter: Facter is a lightweight program that gathers basic node information
-facter: about the hardware and operating system. Facter is especially useful
-facter: for retrieving things like operating system names, hardware
-facter: characteristics, IP addresses, MAC addresses, and SSH keys.
-facter:
-facter: Homepage: http://puppetlabs.com/puppet/related-projects/facter/
-facter:
-facter:
-facter:
diff --git a/system/facter/README b/system/facter/README
new file mode 100644
index 0000000000000..d1c815947db85
--- /dev/null
+++ b/system/facter/README
@@ -0,0 +1,4 @@
+Facter is a lightweight program that gathers basic node information
+about the hardware and operating system. Facter is especially useful
+for retrieving things like operating system names, hardware
+characteristics, IP addresses, MAC addresses, and SSH keys.
diff --git a/system/facter/doinst.sh b/system/facter/doinst.sh
new file mode 100644
index 0000000000000..65ce6d65a5457
--- /dev/null
+++ b/system/facter/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+  NEW="$1"
+  OLD="$(dirname $NEW)/$(basename $NEW .new)"
+  # If there's no config file by that name, mv it over:
+  if [ ! -r $OLD ]; then
+    mv $NEW $OLD
+  elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+    # toss the redundant copy
+    rm $NEW
+  fi
+  # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/facter.conf.new
diff --git a/system/facter/facter-lib64.patch b/system/facter/facter-lib64.patch
new file mode 100644
index 0000000000000..5de8537080ce4
--- /dev/null
+++ b/system/facter/facter-lib64.patch
@@ -0,0 +1,11 @@
+--- lib/CMakeLists.txt.orig	2015-06-30 22:48:00.309505706 +0200
++++ lib/CMakeLists.txt	2015-06-30 22:48:28.407734850 +0200
+@@ -238,7 +238,7 @@
+     set(LIBFACTER_INSTALL_DESTINATION bin)
+ else()
+     # TODO: lib64 for certain operating systems?
+-    set(LIBFACTER_INSTALL_DESTINATION lib)
++    set(LIBFACTER_INSTALL_DESTINATION lib64)
+ endif()
+ 
+ if (JRUBY_SUPPORT)
diff --git a/system/facter/facter.SlackBuild b/system/facter/facter.SlackBuild
new file mode 100644
index 0000000000000..2aeae6021f633
--- /dev/null
+++ b/system/facter/facter.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+
+# Slackware build script for facter
+
+# Copyright 2012-2015 Thibaut Notteboom, Paris, FRANCE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
+#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=facter
+VERSION=${VERSION:-3.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i486 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+else
+  SLKCFLAGS="-O2"
+  LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+if [ "$ARCH" = "x86_64" ]; then
+  patch -p0 < $CWD/facter-lib64.patch
+fi
+
+mkdir -p build
+cd build
+  cmake \
+    -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+    -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DCMAKE_VERBOSE_MAKEFILE=ON \
+    -DCMAKE_BUILD_TYPE=Release ..
+  make
+  make install DESTDIR=$PKG
+cd ..
+    #-DLIBDIR=lib${LIBDIRSUFFIX} \
+
+mv $PKG/usr/share/man $PKG/usr/man
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CONTRIBUTING.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/facter/facter.info b/system/facter/facter.info
new file mode 100644
index 0000000000000..38583b3828a40
--- /dev/null
+++ b/system/facter/facter.info
@@ -0,0 +1,10 @@
+PRGNAM="facter"
+VERSION="3.0.1"
+HOMEPAGE="https://puppetlabs.com/facter/"
+DOWNLOAD="https://downloads.puppetlabs.com/facter/facter-3.0.1.tar.gz"
+MD5SUM="c5ce03ec246c10a0694dea397c59bc1f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="yaml-cpp"
+MAINTAINER="Thibaut Notteboom"
+EMAIL="thibaut.notteboom@gmail.com"
diff --git a/system/facter/slack-desc b/system/facter/slack-desc
new file mode 100644
index 0000000000000..3c812303910e2
--- /dev/null
+++ b/system/facter/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+      |-----handy-ruler------------------------------------------------------|
+facter: Facter (Ruby module for collecting facts about a host OS)
+facter:
+facter: Facter is a lightweight program that gathers basic node information
+facter: about the hardware and operating system. Facter is especially useful
+facter: for retrieving things like operating system names, hardware
+facter: characteristics, IP addresses, MAC addresses, and SSH keys.
+facter:
+facter: Homepage: https://puppetlabs.com/facter/
+facter:
+facter:
+facter:
-- 
cgit v1.2.3