aboutsummaryrefslogtreecommitdiff
path: root/system/powertop/powertop.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/powertop/powertop.SlackBuild')
-rw-r--r--system/powertop/powertop.SlackBuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/system/powertop/powertop.SlackBuild b/system/powertop/powertop.SlackBuild
index 5a71e4707a693..3a5f9dbd25820 100644
--- a/system/powertop/powertop.SlackBuild
+++ b/system/powertop/powertop.SlackBuild
@@ -7,7 +7,7 @@
set -e
PRGNAM=powertop
-VERSION=1.2
+VERSION=1.7
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -31,16 +31,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+# Patch the Makefile to:
+# Put the man page in the correct location
+# Use max compression on the man page
+# Handle $CFLAGS a bit more nicely
+patch < $CWD/Makefile.patch
+
CFLAGS="$SLKCFLAGS" make
make install DESTDIR=$PKG
-# Strip the binary
strip --strip-unneeded $PKG/usr/bin/powertop
-# The makefile does not install the man page. We do that here.
-mkdir -p $PKG/usr/man/man1
-cat powertop.1 | gzip -9c > $PKG/usr/man/man1/powertop.1.gz
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING Changelog README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild