aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2024-10-08 11:02:44 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-10-11 11:48:39 +0700
commitd8986950d4962a52f68cb229868d4615ec9cf377 (patch)
tree8c8d4805e1be9454b4061d5ae0b423da19d6e2b7 /python
parente89e7191bbf60f0bd3e4c8a553d8be00f8b88cae (diff)
python/python3-configobj: Added (Python3 version of configobj).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-configobj/README8
-rw-r--r--python/python3-configobj/python3-configobj.SlackBuild73
-rw-r--r--python/python3-configobj/python3-configobj.info12
-rw-r--r--python/python3-configobj/slack-desc19
4 files changed, 112 insertions, 0 deletions
diff --git a/python/python3-configobj/README b/python/python3-configobj/README
new file mode 100644
index 000000000000..a653d1cfb776
--- /dev/null
+++ b/python/python3-configobj/README
@@ -0,0 +1,8 @@
+python3-configobj (configuration file python module)
+
+A python module for ultra simple handling of configuration files.
+Also useful for human readable data persistence. Flexible and simple.
+
+Upgrade note: the former libraries/configobj build has been removed,
+and replaced with python2-configobj and python3-configobj. If you
+still have configobj installed, you should remove it.
diff --git a/python/python3-configobj/python3-configobj.SlackBuild b/python/python3-configobj/python3-configobj.SlackBuild
new file mode 100644
index 000000000000..479f56be44ba
--- /dev/null
+++ b/python/python3-configobj/python3-configobj.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/bash
+
+# Slackware build script for python2-configobj
+
+# Written by B. Watson (urchlay@slackware.uk)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# This and python2-configobj replace the old libraries/configobj,
+# split into separate py2 and py3, and put in the python/ category.
+
+# Upstream's CHANGES.rst claims that configobj-5.0.9 drops support for
+# python2, but that's not actually true. Most likely, when/if 5.0.10
+# comes out, it really will drop python2, so this build will get updated
+# and python2-configobj will stay at 5.0.9 (if we still need it, by then).
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-configobj
+SRCNAM=configobj
+VERSION=${VERSION:-5.0.9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+# Pure python code, no need for CFLAGS or LIBDIRSUFFIX.
+# We can't use noarch, since python modules go in either lib or lib64.
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+tar xvfC $CWD/$SRCNAM-$VERSION-prebuilt-docs.tar.xz $SRCNAM-$VERSION
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+python3 setup.py install --root=$PKG
+
+# Note: API docs in this package were built by extracting the source
+# and running "make -C docs html" on a box with Sphinx installed.
+# To avoid a Sphinx dep, I'm providing them prebuilt.
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a CHANGES.rst README.md LICENSE docs/_build/html $PKGDOC
+cat $CWD/README > $PKGDOC/README
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-configobj/python3-configobj.info b/python/python3-configobj/python3-configobj.info
new file mode 100644
index 000000000000..c0017674a0b8
--- /dev/null
+++ b/python/python3-configobj/python3-configobj.info
@@ -0,0 +1,12 @@
+PRGNAM="python3-configobj"
+VERSION="5.0.9"
+HOMEPAGE="https://pypi.org/project/configobj/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/c/configobj/configobj-5.0.9.tar.gz \
+ https://slackware.uk/~urchlay/src/configobj-5.0.9-prebuilt-docs.tar.xz"
+MD5SUM="496b60edcd943a900ddc0cb04132e81c \
+ 72599d2673dfabc5f23a31b69b0ae420"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"
diff --git a/python/python3-configobj/slack-desc b/python/python3-configobj/slack-desc
new file mode 100644
index 000000000000..c41306d046e3
--- /dev/null
+++ b/python/python3-configobj/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-configobj: python3-configobj (configuration file python module)
+python3-configobj:
+python3-configobj: A python module for ultra simple handling of configuration files.
+python3-configobj: Also useful for human readable data persistence. Flexible and simple.
+python3-configobj:
+python3-configobj:
+python3-configobj:
+python3-configobj:
+python3-configobj:
+python3-configobj:
+python3-configobj: