aboutsummaryrefslogtreecommitdiff
path: root/python/python2-txaio
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:46 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:04 +0700
commit876dae8127f136b9d31d4e926e4ec6786e59e2f1 (patch)
treebe5a9bc6a7d1c46c3e12ab8812729a5c660a84b9 /python/python2-txaio
parent1fb3a2c91212a810ac2225cd395c08531e9e4bb1 (diff)
python/python-txaio: Renamed python2-txaio.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-txaio')
-rw-r--r--python/python2-txaio/README4
-rw-r--r--python/python2-txaio/python2-txaio.SlackBuild87
-rw-r--r--python/python2-txaio/python2-txaio.info10
-rw-r--r--python/python2-txaio/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/python2-txaio/README b/python/python2-txaio/README
new file mode 100644
index 0000000000000..61b2a59c8c90e
--- /dev/null
+++ b/python/python2-txaio/README
@@ -0,0 +1,4 @@
+txaio is a helper library for writing code that runs unmodified on both
+Twisted and asyncio / Trollius. This is like six, but for wrapping
+over differences between Twisted and asyncio so one can write code that
+runs unmodified on both.
diff --git a/python/python2-txaio/python2-txaio.SlackBuild b/python/python2-txaio/python2-txaio.SlackBuild
new file mode 100644
index 0000000000000..586fe383b8e47
--- /dev/null
+++ b/python/python2-txaio/python2-txaio.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for python-txaio
+
+# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python2-txaio
+VERSION=${VERSION:-18.8.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-txaio/python2-txaio.info b/python/python2-txaio/python2-txaio.info
new file mode 100644
index 0000000000000..15456019e5313
--- /dev/null
+++ b/python/python2-txaio/python2-txaio.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-txaio"
+VERSION="18.8.1"
+HOMEPAGE="https://pypi.python.org/pypi/txaio"
+DOWNLOAD="https://files.pythonhosted.org/packages/c1/99/81de004578e9afe017bb1d4c8968088a33621c05449fe330bdd7016d5377/txaio-18.8.1.tar.gz"
+MD5SUM="ecdd4d0f401c7f01f22830b4d2788593"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python2-twisted"
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/python/python2-txaio/slack-desc b/python/python2-txaio/slack-desc
new file mode 100644
index 0000000000000..616c6c10a2975
--- /dev/null
+++ b/python/python2-txaio/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-txaio: python2-txaio (source code compatibility for Twisted/Trollius)
+python2-txaio:
+python2-txaio: txaio is a helper library for writing code that runs unmodified on
+python2-txaio: both Twisted and asyncio / Trollius.
+python2-txaio:
+python2-txaio: https://pypi.python.org/pypi/txaio
+python2-txaio:
+python2-txaio:
+python2-txaio:
+python2-txaio:
+python2-txaio: