aboutsummaryrefslogtreecommitdiff
path: root/python/python-keyutils
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:38 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:00 +0700
commitb13eb3db5d307b714e52b6e289e9507262b96317 (patch)
treee1cdd19c4377753da29b00b14b1dfbfe51ae1959 /python/python-keyutils
parent5e9e1e6a35fce481036a99d9ccc38c8fc74ca4a4 (diff)
python/python-keyutils: Renamed python2-keyutils.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-keyutils')
-rw-r--r--python/python-keyutils/README5
-rw-r--r--python/python-keyutils/python-keyutils.SlackBuild86
-rw-r--r--python/python-keyutils/python-keyutils.info10
-rw-r--r--python/python-keyutils/slack-desc19
4 files changed, 0 insertions, 120 deletions
diff --git a/python/python-keyutils/README b/python/python-keyutils/README
deleted file mode 100644
index 4ec1441822ad..000000000000
--- a/python/python-keyutils/README
+++ /dev/null
@@ -1,5 +0,0 @@
-python-keyutils is a set of python bindings for keyutils
-(available from http://people.redhat.com/~dhowells/keyutils),
-a key management suite that leverages the infrastructure
-provided by the Linux kernel for safely storing and retrieving
-sensitive infromation in your programs.
diff --git a/python/python-keyutils/python-keyutils.SlackBuild b/python/python-keyutils/python-keyutils.SlackBuild
deleted file mode 100644
index f5ac800a2fd5..000000000000
--- a/python/python-keyutils/python-keyutils.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-keyutils
-
-# Copyright 2016-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-keyutils
-SRCNAM=$(echo $PRGNAM | cut -c8-15)
-VERSION=${VERSION:-0.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst ChangeLog LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-keyutils/python-keyutils.info b/python/python-keyutils/python-keyutils.info
deleted file mode 100644
index 7ea024df1cfb..000000000000
--- a/python/python-keyutils/python-keyutils.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-keyutils"
-VERSION="0.5"
-HOMEPAGE="https://github.com/sassoftware/python-keyutils"
-DOWNLOAD="https://pypi.python.org/packages/10/5f/685e3525cef6f276fd29a949b293d190a695b2812333057ad45d82a24918/keyutils-0.5.tar.gz"
-MD5SUM="f5dc103afefc6278991d8bd0ca528ded"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pytest-runner"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-keyutils/slack-desc b/python/python-keyutils/slack-desc
deleted file mode 100644
index 2540e2d88d02..000000000000
--- a/python/python-keyutils/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-keyutils: python-keyutils (keyutils bindings for Python)
-python-keyutils:
-python-keyutils: python-keyutils is a set of python bindings for keyutils a key
-python-keyutils: management suite that leverages the infrastructure provided by
-python-keyutils: the Linux kernel for safely storing and retrieving sensitive
-python-keyutils: infromation in your programs.
-python-keyutils:
-python-keyutils: Homepage: https://github.com/sassoftware/python-keyutils
-python-keyutils:
-python-keyutils:
-python-keyutils: