aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d9758629cc..8d764a9431 100644
--- a/meson.build
+++ b/meson.build
@@ -66,6 +66,14 @@ elif targetos == 'darwin'
iokit = dependency('appleframeworks', modules: 'IOKit')
cocoa = dependency('appleframeworks', modules: 'Cocoa')
hvf = dependency('appleframeworks', modules: 'Hypervisor')
+elif targetos == 'sunos'
+ socket = [cc.find_library('socket'),
+ cc.find_library('nsl'),
+ cc.find_library('resolv')]
+elif targetos == 'haiku'
+ socket = [cc.find_library('posix_error_mapper'),
+ cc.find_library('network'),
+ cc.find_library('bsd')]
endif
glib = declare_dependency(compile_args: config_host['GLIB_CFLAGS'].split(),
link_args: config_host['GLIB_LIBS'].split())