aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 371d571495..71ef66e1d6 100644
--- a/meson.build
+++ b/meson.build
@@ -83,6 +83,8 @@ if 'CONFIG_GNUTLS' in config_host
gnutls = declare_dependency(compile_args: config_host['GNUTLS_CFLAGS'].split(),
link_args: config_host['GNUTLS_LIBS'].split())
endif
+pixman = declare_dependency(compile_args: config_host['PIXMAN_CFLAGS'].split(),
+ link_args: config_host['PIXMAN_LIBS'].split())
seccomp = not_found
if 'CONFIG_SECCOMP' in config_host
seccomp = declare_dependency(compile_args: config_host['SECCOMP_CFLAGS'].split(),
@@ -97,6 +99,16 @@ if 'CONFIG_LIBISCSI' in config_host
libiscsi = declare_dependency(compile_args: config_host['LIBISCSI_CFLAGS'].split(),
link_args: config_host['LIBISCSI_LIBS'].split())
endif
+gbm = not_found
+if 'CONFIG_GBM' in config_host
+ gbm = declare_dependency(compile_args: config_host['GBM_CFLAGS'].split(),
+ link_args: config_host['GBM_LIBS'].split())
+endif
+virgl = not_found
+if 'CONFIG_VIRGL' in config_host
+ virgl = declare_dependency(compile_args: config_host['VIRGL_CFLAGS'].split(),
+ link_args: config_host['VIRGL_LIBS'].split())
+endif
target_dirs = config_host['TARGET_DIRS'].split()
have_user = false
@@ -265,6 +277,9 @@ if have_tools
if 'CONFIG_VHOST_USER' in config_host
subdir('contrib/libvhost-user')
subdir('contrib/vhost-user-blk')
+ if 'CONFIG_LINUX' in config_host
+ subdir('contrib/vhost-user-gpu')
+ endif
subdir('contrib/vhost-user-input')
subdir('contrib/vhost-user-scsi')
endif