aboutsummaryrefslogtreecommitdiff
path: root/hw/smbios/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/smbios/meson.build')
-rw-r--r--hw/smbios/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/hw/smbios/meson.build b/hw/smbios/meson.build
new file mode 100644
index 0000000000..9e762c7108
--- /dev/null
+++ b/hw/smbios/meson.build
@@ -0,0 +1,13 @@
+smbios_ss = ss.source_set()
+smbios_ss.add(files('smbios.c'))
+smbios_ss.add(when: 'CONFIG_IPMI',
+ if_true: files('smbios_type_38.c'),
+ if_false: files('smbios_type_38-stub.c'))
+
+softmmu_ss.add_all(when: 'CONFIG_SMBIOS', if_true: smbios_ss)
+softmmu_ss.add(when: 'CONFIG_SMBIOS', if_false: files('smbios-stub.c'))
+
+softmmu_ss.add(when: 'CONFIG_ALL', if_true: files(
+ 'smbios-stub.c',
+ 'smbios_type_38-stub.c',
+))