aboutsummaryrefslogtreecommitdiff
path: root/target/mips/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <f4bug@amsat.org>2020-12-06 20:29:00 +0100
committerPhilippe Mathieu-Daudé <f4bug@amsat.org>2020-12-13 19:58:54 +0100
commit2fd9c5ad4449c862932b21e8f6b4573cc50b9ae8 (patch)
tree44ea62b782d76e76685ad82d98701a05ec4be8b0 /target/mips/meson.build
parentdf6adb68c1b1808f164c9ed8a04fe14d9c04e82c (diff)
hw/mips: Move address translation helpers to target/mips/
Address translation is an architectural thing (not hardware related). Move the helpers from hw/ to target/. As physical address and KVM are specific to system mode emulation, restrict this file to softmmu, so it doesn't get compiled for user-mode emulation. Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20201206233949.3783184-2-f4bug@amsat.org>
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index 681a5524c0..4179395a8e 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -14,6 +14,7 @@ mips_ss.add(when: 'CONFIG_KVM', if_true: files('kvm.c'))
mips_softmmu_ss = ss.source_set()
mips_softmmu_ss.add(files(
+ 'addr.c',
'cp0_helper.c',
'cp0_timer.c',
'machine.c',