aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJoelle van Dyne <j@getutm.app>2021-03-15 11:03:41 -0700
committerPaolo Bonzini <pbonzini@redhat.com>2021-05-04 14:15:35 +0200
commitb8e0c4938b610a56028303dd8a2429cf1de71bb8 (patch)
treef3b22cab5d72b16ffd82ee92eaa9ceae0bd95317 /meson.build
parent4951967d84a0acbf47895add9158e2d4c6056ea0 (diff)
slirp: add configure option to disable smbd
Replace Windows specific macro with a more generic feature detection macro. Allows slirp smb feature to be disabled manually as well. Acked-by: Samuel Thibault <samuel.thibault@ens-lyon.org> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Signed-off-by: Joelle van Dyne <j@getutm.app> Message-Id: <20210315180341.31638-5-j@getutm.app> [Use $default_feature as the default. - Paolo] Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2829ed2b86..0b41ff4118 100644
--- a/meson.build
+++ b/meson.build
@@ -2469,7 +2469,7 @@ summary_info += {'genisoimage': config_host['GENISOIMAGE']}
if targetos == 'windows' and config_host.has_key('CONFIG_GUEST_AGENT')
summary_info += {'wixl': wixl.found() ? wixl.full_path() : false}
endif
-if slirp_opt != 'disabled'
+if slirp_opt != 'disabled' and 'CONFIG_SLIRP_SMBD' in config_host
summary_info += {'smbd': config_host['CONFIG_SMBD_COMMAND']}
endif
summary(summary_info, bool_yn: true, section: 'Host binaries')