aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth <thuth@redhat.com>2023-07-05 15:36:39 +0200
committerThomas Huth <thuth@redhat.com>2023-07-10 15:34:57 +0200
commit6db77bb2c1aa1e59b4a04ba3c9b4b8bb17609d48 (patch)
tree4a11066421db0200a5195fc68a10155e599ae2b7 /meson.build
parent9ffcbe2a60d24fc20b98f010dbca244df1fe82c5 (diff)
meson.build: Skip C++ detection unless we're targeting Windows
The only C++ code that we currently still have in the repository is the code in qga/vss-win32/ - so we can skip the C++ detection unless we are compiling binaries for Windows. Message-Id: <20230705133639.146073-1-thuth@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 58413d44a5..162e664c2b 100644
--- a/meson.build
+++ b/meson.build
@@ -20,7 +20,7 @@ config_host = keyval.load(meson.current_build_dir() / 'config-host.mak')
cc = meson.get_compiler('c')
all_languages = ['c']
-if add_languages('cpp', required: false, native: false)
+if targetos == 'windows' and add_languages('cpp', required: false, native: false)
all_languages += ['cpp']
cxx = meson.get_compiler('cpp')
endif