aboutsummaryrefslogtreecommitdiff
path: root/hw/nios2/meson.build
diff options
context:
space:
mode:
authorDaniel Henrique Barboza <danielhb413@gmail.com>2022-09-26 14:38:45 -0300
committerDaniel Henrique Barboza <danielhb413@gmail.com>2022-10-17 16:15:10 -0300
commit610cba317c28d1b4ecb6ea36c754c225f4b917ad (patch)
tree6e8804aacd79c6e27b0403382f10e1de02603be1 /hw/nios2/meson.build
parentbf353ad55590f227d8b96b35e4c8bd6ab1a3d8de (diff)
hw/nios2: set machine->fdt in nios2_load_dtb()
This will enable support for 'dumpdtb' QMP/HMP command for all nios2 machines that uses nios2_load_dtb(). Cc: Chris Wulff <crwulff@gmail.com> Cc: Marek Vasut <marex@denx.de> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Signed-off-by: Daniel Henrique Barboza <danielhb413@gmail.com> Message-Id: <20220926173855.1159396-7-danielhb413@gmail.com>
Diffstat (limited to 'hw/nios2/meson.build')
-rw-r--r--hw/nios2/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/hw/nios2/meson.build b/hw/nios2/meson.build
index 6c58e8082b..22277bd6c5 100644
--- a/hw/nios2/meson.build
+++ b/hw/nios2/meson.build
@@ -1,5 +1,5 @@
nios2_ss = ss.source_set()
-nios2_ss.add(files('boot.c'))
+nios2_ss.add(files('boot.c'), fdt)
nios2_ss.add(when: 'CONFIG_NIOS2_10M50', if_true: files('10m50_devboard.c'))
nios2_ss.add(when: 'CONFIG_NIOS2_GENERIC_NOMMU', if_true: files('generic_nommu.c'))