aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-05-19 10:03:26 +0100
committerfanquake <fanquake@gmail.com>2023-05-19 10:05:15 +0100
commit2f1403ae530765130f92dbf32b6aabaca0312ba0 (patch)
treec32f5eb3e666b1bf5f60148fa98b1f92f351f69e /configure.ac
parentedd6d8395f5dd00ea9fc54d9de1ad4ad236aa5b3 (diff)
parentb53cab0083d99e9610d74517d1d41fc615953770 (diff)
Merge bitcoin/bitcoin#27458: build: Detect USDT the same way how it is used in the code
b53cab0083d99e9610d74517d1d41fc615953770 build: Detect USDT the same way how it is used in the code (Hennadii Stepanov) Pull request description: In the code we do not use string literals. Also a check for `DTRACE_PROBE7` macro has been added as not all systems define`DTRACE_PROBE{6,7,8,9,10,11,12}` macros (e.g., FreeBSD). ACKs for top commit: 0xB10C: ACK b53cab0083d99e9610d74517d1d41fc615953770 Tree-SHA512: 74f49424d57bf1929f2b09edba1449cef5a1a2448161952da35302343f3003d5bedeab1417e166b656c5f629303e2de888550b1219e886a1b991b12b9c880794
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index db1b7f758a..97b970161c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1409,7 +1409,9 @@ if test "$use_usdt" != "no"; then
AC_COMPILE_IFELSE([
AC_LANG_PROGRAM(
[#include <sys/sdt.h>],
- [DTRACE_PROBE("context", "event");]
+ [DTRACE_PROBE(context, event);
+ int a, b, c, d, e, f, g;
+ DTRACE_PROBE7(context, event, a, b, c, d, e, f, g);]
)],
[AC_MSG_RESULT([yes]); AC_DEFINE([ENABLE_TRACING], [1], [Define to 1 to enable tracepoints for Userspace, Statically Defined Tracing])],
[AC_MSG_RESULT([no]); use_usdt=no;]